苹果和谷歌加速冠状病毒接触者追踪应用计划

苹果和谷歌在向卫生当局提供的接触者追踪计划中加强了隐私保护措施,并推出了该计划。

这些技术巨头现在打算在星期二向开发人员发布一个软件构件,使他们能够构建兼容的应用程序。两周前,两家公司表示将持续到五月中旬。

苹果版本将需要其移动操作系统的更新版本。

但是,有些国家希望这些公司的规定较少。

法国和德国证实,他们正在追求自己的设计,并向苹果施压,要求他们在无需采用该计划的情况下,更好地利用iPhone的功能。
NHS的数字部门NHSX在早些时候发布的博客中证实,其英国联系人跟踪应用程序正在“与Apple和Google合作”,但并未致力于公司的框架。
病毒警报
接触跟踪应用程序基于以下原理:当两个人足够近的距离足够长的时间,如果其中一个人患有冠状病毒,则可能会使用人们的智能手机进行日志记录。

如果随后一位电话所有者被诊断出感染了病毒,则可以向他们发送信号,通知他们可能感染的其他电话所有者,建议他们进行测试或进行自我隔离。

通过将此类应用程序的使用与其他措施(包括人类手动追踪接触和频繁洗手)相结合,希望可以减缓或抑制疾病的传播。
苹果和谷歌的系统基于蓝牙低功耗(LE)信标的使用。实际上,两部手机彼此无线“握手”,并以此交换一串随机生成的数字,这些数字可用于记录比赛,而无需透露用户的姓名,位置或其他识别信息。

负责团队的代表说,他们已经听取了卫生当局,政府和数据保护监管机构的反馈,并进行了更改,以提高安全性并简化使用API​​(应用程序编程接口)构建模块构建应用程序的过程。正在提供。

这些更改包括:

提供有关不同设备的蓝牙功率水平的信息,以帮助开发人员更好地估计两部手机之间的距离
让开发人员自己决定手机应该多近距离以及触发一次握手的时间
防止电话记录任何持续时间超过30分钟的会议
对有关电话传输功率的数据进行加密,以防止任何人追溯使用日志来揭示涉及的型号
更改为另一种加密算法-AES-以减少电池使用时间
苹果将​​要求用户安装新版本的iOS 13才能使用该API。这意味着任何比iPhone 6S(2015年9月发布)更早的手机都将不兼容。

任何运行于2015年10月或更高版本的Google操作系统第6版的Android设备都可以运行,而无需更新。
背景蓝牙
苹果和谷歌的系统被描述为“去中心化”,因为联系人匹配发生在用户的设备上,除非用户决定公开事实(例如请求诊断),否则当局无法看到谁收到了警报。测试。

但是一些国家正在追求“集中式”设计。这将使他们对发出的警报数量有更多的了解,并有可能重新识别用户,这意味着他们将不会真正匿名。
但是,这些国家/地区的软件版本面临iPhone问题。苹果对第三方应用程序对蓝牙的使用设置了限制,只有当当局采用其计划时,它才会被放弃。

“在后台运行该应用程序时,蓝牙在iOS上受到严格限制,”正在开发与Google-Apple兼容的应用程序的开发商Quentin Zervaas解释说。

“它可以用于在后台时偶尔广播或接收数据,但不能保证这种频率有多高,而且该应用程序会与手机上尝试使用蓝牙的任何其他应用程序竞争。

“因此,对于联系人跟踪,它无法不断发送或接收必要的数据,以有效地跟踪与您接触的每台设备。

“ [这就是为什么我认为所有联系人跟踪应用程序都应该使用Apple和Google推出的系统级工具的原因。”

苹果和谷歌拒绝讨论选择单独使用它的国家的含义。

(source)

发表评论

邮箱地址不会被公开。 必填项已用*标注